Yes. Sniip is fully compliant with PCI-DSS Level 3.2 for Service Providers (version 3.2).